绘世启动器升级 SD-WebUI 后插件无法使用

共计 566 个字符,预计需要花费 2 分钟才能阅读完成。

绘世启动器升级 SD-WebUI 后插件无法使用

在升级 SD-WebUI 后,您可能会遇到一些插件无法正常使用的问题。这是因为在版本切换过程中,部分插件可能会运行在与设计的 SD-WebUI 版本不一致的环境上,导致启动时报错而被自动禁用。常见的报错信息可能是类似于“Error loading script: ***.py”的提示。

SD-WebUI 并没有设计任何版本号机制或者版本间的兼容机制,因此需要使用者自行将 SD-WebUI 版本与插件版本对齐。为了解决这个问题,您可以使用启动器的扩展管理工具来完成版本对齐的操作。下面是一些版本对齐的原则和步骤供您参考:

  1. 首先,您需要查找插件的更新日期。通常情况下,插件的更新日期应当晚于当前 SD-WebUI 的更新日期,但是不能相差太大。
  2. 使用启动器的扩展管理工具,找到您想要使用的插件,并检查其版本信息。如果插件的版本较旧,您可以尝试更新插件到最新版本,以确保与当前的 SD-WebUI 版本兼容。
  3. 如果更新插件后仍然无法正常使用,您可以尝试降低 SD-WebUI 的版本,直到启动时不再报错。这意味着您需要前后调整 SD-WebUI 的版本,直到插件能够在不报错的情况下正常启动。

通过以上的步骤,您应该能够解决升级 SD-WebUI 后插件无法使用的问题。请注意,在进行版本对齐的过程中,确保插件与 SD-WebUI 版本的兼容性是非常重要的,这样才能保证插件能够正常运行。

正文完